re = /(?<=\"compliantNotes\": \").*(?=\"\s+\"compliantDetected\":)/mi
str = '"compliantNotes": " this is
the text I expect, works in Chrome, but not in IE" "compliantDetected": blah
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end