const regex = /(.*)\((.*)\)(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\((.*)\\)(.*)', '')
const str = `Vithursan (Je suis occupé) 06 59 15 61 49`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);