#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?isU)<object\s*[^>]*[^/]>.*</object>|<object\s*[^>]*/>"
Local $sString = "<object id="my-fake-object">" & @CRLF & _
" ..." & @CRLF & _
"</object>" & @CRLF & _
"<!-- " & @CRLF & _
" Questa è un commento in HTML" & @CRLF & _
" questo <object > è un tag intenzionalmente messo per dimostrare" & @CRLF & _
" quanto può essere pericoloso questo approccio." & @CRLF & _
"-->" & @CRLF & _
"<p>" & @CRLF & _
" Questo contenuto è totalmente innocuo, eppure verrà rimosso." & @CRLF & _
"</p>" & @CRLF & _
"" & @CRLF & _
"<object id="my-fake-object-2">" & @CRLF & _
" ..." & @CRLF & _
"</object>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")