const regex = new RegExp('<object\\s*[^>]*[^/]>.*</object>|<object\\s*[^>]*/>', 'isg')
const str = `<object id="my-fake-object">
...
</object>
<!--
Questa è un commento in HTML
questo <object > è un tag intenzionalmente messo per dimostrare
quanto può essere pericoloso questo approccio.
-->
<p>
Questo contenuto è totalmente innocuo, eppure verrà rimosso.
</p>
<object id="my-fake-object-2">
...
</object>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}