// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?isU)<object\s*[^>]*[^/]>.*</object>|<object\s*[^>]*/>").unwrap();
let string = "<object id=\"my-fake-object\">
...
</object>
<!--
Questa è un commento in HTML
questo <object > è un tag intenzionalmente messo per dimostrare
quanto può essere pericoloso questo approccio.
-->
<p>
Questo contenuto è totalmente innocuo, eppure verrà rimosso.
</p>
<object id=\"my-fake-object-2\">
...
</object>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}