import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<object\\s*[^>]*[^/]>.*</object>|<object\\s*[^>]*/>";
final String string = "<object id=\"my-fake-object\">\n"
+ " ...\n"
+ "</object>\n"
+ "<!-- \n"
+ " Questa è un commento in HTML\n"
+ " questo <object > è un tag intenzionalmente messo per dimostrare\n"
+ " quanto può essere pericoloso questo approccio.\n"
+ "-->\n"
+ "<p>\n"
+ " Questo contenuto è totalmente innocuo, eppure verrà rimosso.\n"
+ "</p>\n\n"
+ "<object id=\"my-fake-object-2\">\n"
+ " ...\n"
+ "</object>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}