$re = '~<object\s*[^>]*[^/]>.*</object>|<object\s*[^>]*/>~isU';
$str = '<object id="my-fake-object">
...
</object>
<!--
Questa è un commento in HTML
questo <object > è un tag intenzionalmente messo per dimostrare
quanto può essere pericoloso questo approccio.
-->
<p>
Questo contenuto è totalmente innocuo, eppure verrà rimosso.
</p>
<object id="my-fake-object-2">
...
</object>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);