import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<table.*?>(.*?)<\\/table>";
final String string = "<table class=\"table table-bordered table-striped\"><a target=\"_blank\" href=\"http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg\">http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg</a></td></tr><tr><td>Width</td><td>400</td></tr><tr><td>Height</td><td>267</td></tr><tr><td>Alt</td><td>AMILLA FUSHI-AERIALS-PHOTO-4009</td></tr></tbody></table>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}