use strict;
my $str = '<table class="table table-bordered table-striped"><a target="_blank" href="http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg">http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg</a></td></tr><tr><td>Width</td><td>400</td></tr><tr><td>Height</td><td>267</td></tr><tr><td>Alt</td><td>AMILLA FUSHI-AERIALS-PHOTO-4009</td></tr></tbody></table>';
my $regex = qr/<table.*?>(.*?)<\/table>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}