re = /<table.*?>(.*?)<\/table>/
str = '<table class="table table-bordered table-striped"><a target="_blank" href="http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg">http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg</a></td></tr><tr><td>Width</td><td>400</td></tr><tr><td>Height</td><td>267</td></tr><tr><td>Alt</td><td>AMILLA FUSHI-AERIALS-PHOTO-4009</td></tr></tbody></table>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end