const regex = /<table.*?>(.*?)<\/table>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<table.*?>(.*?)<\\\/table>', '')
const str = `<table class="table table-bordered table-striped"><a target="_blank" href="http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg">http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg</a></td></tr><tr><td>Width</td><td>400</td></tr><tr><td>Height</td><td>267</td></tr><tr><td>Alt</td><td>AMILLA FUSHI-AERIALS-PHOTO-4009</td></tr></tbody></table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}