# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<table.*?>(.*?)<\/table>"
test_str = "<table class=\"table table-bordered table-striped\"><a target=\"_blank\" href=\"http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg\">http://amilla.smugmug.com/Amilla-Fushi-Your-Island-Home/ALLBESTPHOTOS/i-22s2QVL/0/S/AMILLA%20FUSHI-AERIALS-PHOTO-4009-S.jpg</a></td></tr><tr><td>Width</td><td>400</td></tr><tr><td>Height</td><td>267</td></tr><tr><td>Alt</td><td>AMILLA FUSHI-AERIALS-PHOTO-4009</td></tr></tbody></table>"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.