package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+[0-9]{2}[.\-\s]?|00[.\-\s]?[0-9]{2}|0)([0-9]{1,3}[.\-\s]?(?:[0-9]{2}[.\-\s]?){4})$`)
var str = `0512345678
05 12 34 56 78
05.12.34.56.78
05-12-34-56-78
+33621325465
+336 21 32 54 65
+336.21.32.54.65
+336-21-32-54-65
0033621325465
00336 21 32 54 65
00336.21.32.54.65
00336-21-32-54-65`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}