import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+[0-9]{2}[.\\-\\s]?|00[.\\-\\s]?[0-9]{2}|0)([0-9]{1,3}[.\\-\\s]?(?:[0-9]{2}[.\\-\\s]?){4})$";
final String string = "0512345678\n"
+ "05 12 34 56 78\n"
+ "05.12.34.56.78\n"
+ "05-12-34-56-78\n"
+ "+33621325465\n"
+ "+336 21 32 54 65\n"
+ "+336.21.32.54.65\n"
+ "+336-21-32-54-65\n"
+ "0033621325465\n"
+ "00336 21 32 54 65\n"
+ "00336.21.32.54.65\n"
+ "00336-21-32-54-65";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}