const regex = /^(\+[0-9]{2}[.\-\s]?|00[.\-\s]?[0-9]{2}|0)([0-9]{1,3}[.\-\s]?(?:[0-9]{2}[.\-\s]?){4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+[0-9]{2}[.\\-\\s]?|00[.\\-\\s]?[0-9]{2}|0)([0-9]{1,3}[.\\-\\s]?(?:[0-9]{2}[.\\-\\s]?){4})$', 'gm')
const str = `0512345678
05 12 34 56 78
05.12.34.56.78
05-12-34-56-78
+33621325465
+336 21 32 54 65
+336.21.32.54.65
+336-21-32-54-65
0033621325465
00336 21 32 54 65
00336.21.32.54.65
00336-21-32-54-65`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}