import re
regex = re.compile(r"^(\+[0-9]{2}[.\-\s]?|00[.\-\s]?[0-9]{2}|0)([0-9]{1,3}[.\-\s]?(?:[0-9]{2}[.\-\s]?){4})$", flags=re.MULTILINE)
test_str = ("0512345678\n"
"05 12 34 56 78\n"
"05.12.34.56.78\n"
"05-12-34-56-78\n"
"+33621325465\n"
"+336 21 32 54 65\n"
"+336.21.32.54.65\n"
"+336-21-32-54-65\n"
"0033621325465\n"
"00336 21 32 54 65\n"
"00336.21.32.54.65\n"
"00336-21-32-54-65")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")