#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)# single line demo (do not use multiline input for testing this)" & @CRLF & _
"^(?=\D*\d)(?=[^\W_]*[\W_])(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])\S{8,}$"
Local $sString = "FooBar1$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")