const regex = /# single line demo (do not use multiline input for testing this)
^(?=\D*\d)(?=[^\W_]*[\W_])(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])\S{8,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('# single line demo (do not use multiline input for testing this)
^(?=\\D*\\d)(?=[^\\W_]*[\\W_])(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])\\S{8,}$', 'gm')
const str = `FooBar1\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}