$re = '/# single line demo (do not use multiline input for testing this)
^(?=\D*\d)(?=[^\W_]*[\W_])(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])\S{8,}$/mx';
$str = 'FooBar1$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);