import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# single line demo (do not use multiline input for testing this)\n"
+ "^(?=\\D*\\d)(?=[^\\W_]*[\\W_])(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])\\S{8,}$";
final String string = "FooBar1$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}