# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.{6,})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\d)(?=.*?\W).*$//gm;t' <<< "Aæøåa6
asdA9'
sfdsfd89
Adsd87865634x"