use strict;
my $str = 'Aæøåa6
asdA9\'
sfdsfd89
Adsd87865634x';
my $regex = qr/^(?=.{6,})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\d)(?=.*?\W).*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";