const regex = /^(?=.{6,})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\d)(?=.*?\W).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{6,})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\\d)(?=.*?\\W).*$', 'gm')
const str = `Aæøåa6
asdA9'
sfdsfd89
Adsd87865634x`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);