re = /^(?=.{6,})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\d)(?=.*?\W).*$/m
str = 'Aæøåa6
asdA9\'
sfdsfd89
Adsd87865634x'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result