$re = '/^(?=.{6,})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\d)(?=.*?\W).*$/m';
$str = 'Aæøåa6
asdA9\'
sfdsfd89
Adsd87865634x';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;