#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[A-Za-z0-9~!#$%^&*()_+=\-`|\\\/\[\];,{}"']+[A-Za-z0-9~!#$%^&:* ()_+=\-`|\\\/\[\].;,{}"']+@[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\/\[\].;,{}"']+@{0,1}[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\/\[\].;,{}"']+[A-Za-z0-9\]]$"
Local $sString = "vigan@[IPv6:2001:db8::1]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")