re = /^[A-Za-z0-9~!#$%^&*()_+=\-`|\\\/\[\];,{}"']+[A-Za-z0-9~!#$%^&:* ()_+=\-`|\\\/\[\].;,{}"']+@[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\/\[\].;,{}"']+@{0,1}[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\/\[\].;,{}"']+[A-Za-z0-9\]]$/
str = 'vigan@[IPv6:2001:db8::1]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end