using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z0-9~!#$%^&*()_+=\-`|\\\/\[\];,{}""']+[A-Za-z0-9~!#$%^&:* ()_+=\-`|\\\/\[\].;,{}""']+@[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\/\[\].;,{}""']+@{0,1}[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\/\[\].;,{}""']+[A-Za-z0-9\]]$";
string input = @"vigan@[IPv6:2001:db8::1]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}