package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Za-z0-9~!#$%^&*()_+=\-`|\\\/\[\];,{}"']+[A-Za-z0-9~!#$%^&:* ()_+=\-`|\\\/\[\].;,{}"']+@[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\/\[\].;,{}"']+@{0,1}[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\/\[\].;,{}"']+[A-Za-z0-9\]]$`)
var str = `vigan@[IPv6:2001:db8::1]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}