#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!ack|zen):"
Local $sString = "pack: my box with five: dozen: liquor: jugs ::: :" & @CRLF & _
""
Local $sSubst = ";"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)