use strict;
my $str = 'pack: my box with five: dozen: liquor: jugs ::: :
';
my $regex = qr/(?<!ack|zen):/p;
my $subst = ';';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";