const regex = /(?<!ack|zen):/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!ack|zen):', 'g')
const str = `pack: my box with five: dozen: liquor: jugs ::: :
`;
const subst = `;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);