$re = '/(?<!ack|zen):/';
$str = 'pack: my box with five: dozen: liquor: jugs ::: :
';
$subst = ";";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;