using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!ack|zen):";
string substitution = @";";
string input = @"pack: my box with five: dozen: liquor: jugs ::: :
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}