const regex = /href=["\']?(\d{4}(?:[-_]\d{2})+)["\']?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=["\\\']?(\\d{4}(?:[-_]\\d{2})+)["\\\']?', 'g')
const str = `href="XXXX-XX-XX"
href="2015-05-15",
href="2015-05-15_03_21_32"
href="2014-12-21"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}