re = /href=["\']?(\d{4}(?:[-_]\d{2})+)["\']?/
str = 'href="XXXX-XX-XX"
href="2015-05-15",
href="2015-05-15_03_21_32"
href="2014-12-21"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end