// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href=["\']?(\d{4}(?:[-_]\d{2})+)["\']?"#).unwrap();
let string = "href=\"XXXX-XX-XX\"
href=\"2015-05-15\",
href=\"2015-05-15_03_21_32\"
href=\"2014-12-21\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}