import Foundation
let pattern = #"href=["\']?(\d{4}(?:[-_]\d{2})+)["\']?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
href="XXXX-XX-XX"
href="2015-05-15",
href="2015-05-15_03_21_32"
href="2014-12-21"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)