$re = '/href=["\']?(\d{4}(?:[-_]\d{2})+)["\']?/';
$str = 'href="XXXX-XX-XX"
href="2015-05-15",
href="2015-05-15_03_21_32"
href="2014-12-21"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);