using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-([^-]*)-WEB";
string input = @"Psyched_-_Nightstalker-THER148-WEB-2015-SRG
George_FitzGerald-Fading_Love-DS086D-WEB-2015-PITY";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}