import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-([^-]*)-WEB";
final String string = "Psyched_-_Nightstalker-THER148-WEB-2015-SRG\n"
+ "George_FitzGerald-Fading_Love-DS086D-WEB-2015-PITY";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}