re = /-([^-]*)-WEB/
str = 'Psyched_-_Nightstalker-THER148-WEB-2015-SRG
George_FitzGerald-Fading_Love-DS086D-WEB-2015-PITY'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end