// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-([^-]*)-WEB").unwrap();
let string = "Psyched_-_Nightstalker-THER148-WEB-2015-SRG
George_FitzGerald-Fading_Love-DS086D-WEB-2015-PITY";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}