$re = '/-([^-]*)-WEB/';
$str = 'Psyched_-_Nightstalker-THER148-WEB-2015-SRG
George_FitzGerald-Fading_Love-DS086D-WEB-2015-PITY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);