using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([^ >]+).*<\/\1>";
string input = @"<paper-input label=""Input label""> Some text </paper-input>
<paper-input label=""Input label""> Some text </paper-inputa>
<azz> Some text </az>
<az> Some text </az>
<az> Some text </aza>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}