$re = '/<([^ >]+).*<\/\1>/';
$str = '<paper-input label="Input label"> Some text </paper-input>
<paper-input label="Input label"> Some text </paper-inputa>
<azz> Some text </az>
<az> Some text </az>
<az> Some text </aza>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);