re = /<([^ >]+).*<\/\1>/
str = '<paper-input label="Input label"> Some text </paper-input>
<paper-input label="Input label"> Some text </paper-inputa>
<azz> Some text </az>
<az> Some text </az>
<az> Some text </aza>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end