import re
regex = re.compile(r"<([^ >]+).*<\/\1>")
test_str = ("<paper-input label=\"Input label\"> Some text </paper-input>\n"
"<paper-input label=\"Input label\"> Some text </paper-inputa>\n"
"<azz> Some text </az>\n"
"<az> Some text </az>\n"
"<az> Some text </aza>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")