using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]+href=""(.*?)""";
string input = @"<h2>Пример использования</h2><a href=""http://test.me/please"">Ссылка1</a>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}