$re = '/<a[^>]+href="(.*?)"/';
$str = '<h2>Пример использования</h2><a href="http://test.me/please">Ссылка1</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);